WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#16912 closed defect (bug) (fixed)

Quick edit error message styling lost in 3.1

Reported by: solarissmoke Owned by: azaozz
Milestone: 3.2 Priority: normal
Severity: normal Version: 3.1
Component: Editor Keywords: has-patch
Focuses: Cc:

Description

In WP 3.0, quick edit error messages for posts (e.g., if someone else has lock on a post, and you try to save a quick edit) were put in a red box with a light red background.

In 3.1 this styling has been lost. The error just appears as normal text.

The change occurred in [16205].

Attachments (2)

16912.diff (1.6 KB) - added by solarissmoke 3 years ago.
16912-screenshot.png (14.4 KB) - added by duck_ 3 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 ocean903 years ago

  • Milestone changed from Awaiting Review to 3.1.1

solarissmoke3 years ago

comment:2 solarissmoke3 years ago

  • Keywords has-patch added; needs-patch removed

Patch makes the error message handling consistent with inline edit elsewhere (comments, link categories etc all do it this way, with a hidden error span element). Also adds color:red. There also used to be a light red background but I'm not sure that is necessary..

Incidentally this will also fix #14317.

comment:3 ocean903 years ago

Version 0, edited 3 years ago by ocean90 (next)

duck_3 years ago

comment:4 ryan3 years ago

  • Milestone changed from 3.1.1 to 3.2

Punting to 3.2 per bug scrub.

comment:5 johnjamesjacoby3 years ago

Tested. Patch applies clean. The style is not particularly as beautiful as the rest of the UI, but does get the point across.

comment:6 azaozz3 years ago

@scribu trying to figure out why the global .error and .updated CSS classes were limited to DIVs only in [16205]. There is no mention about it in the ticket or the commit message. This looks like a regression and removing the limitation doesn't seem to affect anything in the admin.

comment:7 azaozz3 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In [18158]:

Fix quick edit error message styling, props solarissmoke, fixes #16912, fixes #14317
Fix top margin in bulk edit posts

Note: See TracTickets for help on using tickets.