WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#16917 closed defect (bug) (fixed)

Bump PHP and MySQL required versions

Reported by: markjaquith Owned by:
Milestone: 3.2 Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

We're bumping the minimum PHP version to 5.2.4, and are bumping the minimum MySQL version to 5.0. This is a ticket to track that.

To-do: update WP.org API to not offer WP >= 3.2 to anyone who doesn't meet the requirements.

Attachments (1)

16917.readme.diff (609 bytes) - added by duck_ 4 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 @markjaquith4 years ago

(In [17523]) Bump PHP requirement to 5.2.4. Bump MySQL requirement to 5.0. see #16917

comment:2 in reply to: ↑ description @nacin4 years ago

Replying to markjaquith:

To-do: update WP.org API to not offer WP >= 3.2 to anyone who doesn't meet the requirements.

The API returns 3.2, but it also returns the PHP version, which is handled in list_core_update(). However the API code wasn't written to handle WP version-specific PHP/MySQL requirements, which I'm working on now.

comment:3 @hakre4 years ago

Duplicate: #16804

comment:4 @dd324 years ago

(In [17534]) Remove PHP4 based WP_Http_Fopen class. Props sivel for initial patch. See #16917 Fixes #13915

comment:5 @hakre4 years ago

Related: #16920

comment:6 in reply to: ↑ description @nacin4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Replying to markjaquith:

To-do: update WP.org API to not offer WP >= 3.2 to anyone who doesn't meet the requirements.

Done: http://api.wordpress.org/core/version-check/1.5/?version=3.2.

@duck_4 years ago

comment:7 @duck_4 years ago

Readme "System Requirements" need bumping too.

comment:8 @nacin4 years ago

(In [17562]) Bump readme system requirements. props duck_, see #16917.

Note: See TracTickets for help on using tickets.