Make WordPress Core

Opened 13 years ago

Closed 11 years ago

Last modified 11 years ago

#16936 closed defect (bug) (duplicate)

Changing a menu or tag/category title with matching slugs changes both

Reported by: scottcropper's profile scottcropper Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Menus Keywords:
Focuses: Cc:

Description

If a menu is created with a title that matches the slug of a tag or category or vice versa they become connected in the admin. After that if either are edited they both change titles and slugs. This can easily be replicated in a fresh WP 3.1 install with no plugins.

  1. Create either a menu or tag/category with the title test (slug for tag/category should be test).
  2. Then create the other with the same title.
  3. Change either and both will change and have matching titles.

Why would menu names be connected to an individual tag or category? The only purpose I could imagine would be in a template showing a particular tag/category of posts and grabbing a matching menu if one exists. If this is expected behavior then I think its important that this be added to the codex and the admin interface to alert the user to the other changes made.

Change History (5)

#1 @greuben
13 years ago

Dupe of #5809

#2 @scribu
13 years ago

  • Component changed from General to Menus
  • Keywords needs-patch added; 2nd-opinion needs-testing needs-codex removed
  • Milestone changed from Awaiting Review to Future Release

I would close as dup, but maybe we should treat menu creation differently from categories/tags, since the menu slugs aren't visible anywhere.

Kind of how we namespace post formats.

#3 @SergeyBiryukov
12 years ago

Duplicate: #20707 (which in turn was closed as a duplicate of #5809).

#4 @wonderboymusic
11 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

#5 @helenyhou
11 years ago

  • Keywords needs-patch removed
  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.