WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#16941 closed defect (bug) (duplicate)

Editing term overwriting term with same name in another taxonomy

Reported by: hsatterwhite Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Taxonomy Keywords:
Focuses: Cc:

Description

I registered two custom taxonomies, City and County, and then created new terms for each. Creating new terms with identical names in both taxonomies is successful, but if you try to edit the name or slug of the term in one taxonomy it is overwriting the information entered for the term with the identical name in the other taxonomy.

Steps to reproduce:

  1. Register City and County as custom taxonomies
  2. Add a term using just the name field to the City taxonomy
  3. Add a term with the same name using just the name field to the County taxonomy
  4. Edit the name or slug in the County taxonomy
  5. Check the term entry of the same name in the City taxonomy
  6. The term of the same name in the other taxonomy has been changed.

I've tried this using posts and custom post types and I've found that if you add a term of the same name, but define a custom slug, it will add the term and this does not happen. Also deleting a term from one of the taxonomies does not delete the term of the same name from the other taxonomy.

Change History (4)

#1 @sc0ttkclark
10 years ago

+1 on this

#2 @sc0ttkclark
10 years ago

  • Cc lol@… added

#3 @dd32
10 years ago

This is a duplicate of another ticket, But I can't find it.. It may be that it's been closed as partially fixed in a previous version.

#4 @scribu
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.