WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 8 years ago

Last modified 7 years ago

#1696 closed defect (bug) (fixed)

WYSIWYG editor stripping tags

Reported by: joakimlea@… Owned by:
Milestone: Priority: high
Severity: major Version: 2.0.4
Component: Administration Keywords: wysiwyg stripping strip tags tag
Focuses: Cc:

Description

This happens to me on wordpress.com only.

Tags like <a> and <img> gets stripped for all its attributes and ends up in a post like <a>some linktext</a> or <a><img></img></a>

Change History (6)

comment:1 markjaquith9 years ago

Cannot replicate. Could have been a transient issue. Keep in mind that wp.com is very much a work in progress, with active development. In particular, sanitization of html has been worked on, so you may have just caught it at a bad time.

comment:2 markjaquith9 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

comment:3 morpheu58 years ago

  • Keywords stripping strip tags tag added
  • Milestone set to 2.0.4
  • Resolution worksforme deleted
  • Severity changed from normal to major
  • Status changed from closed to reopened
  • Version changed from 1.6 to 2.0.4

This is still appearing and I've been away from my blog for two weeks.

It appeared with version 2.0.3 and now I have 2.0.4. It's happening only on my self-hosted weblog, I've tryied on others but all went just right.

comment:4 morpheu58 years ago

Talking with my host, it seems that the problem is given by PHP Version 5.1.4-pl4-gentoo with Hardening-Patch 0.4.11. He suggested me to convert the post text with htmlentities and html_entity_decode but I'm not so familiar with WP code and for the next three weeks I'll be pretty busy. Will this be fixed in 2.1?

For the moment I'm blogging with Qumana but my other users are pretty upset on using an offline client.

comment:5 morpheu58 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:6 anonymous7 years ago

  • Milestone 2.0.4 deleted

Milestone 2.0.4 deleted

Note: See TracTickets for help on using tickets.