WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 8 months ago

Last modified 8 months ago

#17002 closed defect (bug) (invalid)

Pasting Large Amount of Text Through Paste-from-Word TinyMCE button leads to Whitescreen upon publishing

Reported by: mkgold Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.1
Component: General Keywords:
Focuses: Cc:

Description

I needed to paste a large MS Word document into a WordPress page, so I used the Paste-from-Word button on the Visual Editor to do so. When I tried to publish the page, I got a whitescreen with the URL /wp-admin/post.php

After testing the problem in various ways, I determined that the problem arose only when the amount of words in the page were more than 10,000. The page posted fine when there were fewer than 10,000 words.

Using WordPress 3.1, CommentPress Theme, Mac OS X 10.6.7, Chrome browser

Change History (7)

comment:1 scribu3 years ago

  • Component changed from General to Editor

comment:2 scribu3 years ago

  • Keywords reporter-feedback added

It would be useful if you could add the following line to wp-config.php and tell us what you get:

define('WP_DEBUG', true);

Ignore other notices that may appear until hitting the 'Publish' button.

Last edited 3 years ago by scribu (previous) (diff)

comment:3 mkgold3 years ago

Thanks. I added that line to wp-config.php and did see an error message on the post-writing page. However, When I pasted text through the Paste-from-Word tool and then hit "Publish," I again saw a white screen. No error messages appeared.

comment:4 follow-up: mkgold3 years ago

For what it's worth, here are the error messages I saw on the post-writing page:

Notice: load_plugin_textdomain was called with an argument that is deprecated since version 2.7 with no alternative available. in [path]/wp-includes/functions.php on line 3389

Notice: Undefined index: cp_submit in [path]/wp-content/plugins/commentpress/class_commentpress_db.php on line 610

Notice: Undefined index: cp_nonce in [path]/wp-content/plugins/commentpress/class_commentpress_db.php on line 1235

Notice: load_plugin_textdomain was called with an argument that is deprecated since version 2.7 with no alternative available. in [path]/wp-includes/functions.php on line 3389

Warning: Cannot modify header information - headers already sent by (output started at [path]/wp-includes/functions.php:3389) in [path]/wp-includes/class-wp-ajax-response.php on line 129

comment:5 in reply to: ↑ 4 azaozz3 years ago

  • Component changed from Editor to General

Replying to mkgold:

Most of these errors indicate that the Commentpress plugin needs an update.

Few more questions:

  • Are you logged in as admin on a single install (i.e. do you have unlimited_html capability).
  • What happens if you try switching to the HTML editor and back before publishing?
  • What happens if you paste the Word content into the HTML editor and publish?
  • Is it possible to try this with all plugins disabled and with the Twenty Ten theme?
  • Does adding define('WP_MEMORY_LIMIT', '128M'); in wp-config.php solve the problem?
Version 0, edited 3 years ago by azaozz (next)

comment:6 c3mdigital8 months ago

  • Keywords close added; reporter-feedback removed
  • Resolution set to invalid
  • Status changed from new to closed

Unable to verify.

mkgold,
If you can still reproduce this bug using azaozz's suggestions above please reopen this ticket.

comment:7 helen8 months ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.