WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#17029 closed feature request (fixed)

Show hierarchy in Pages box on Menus screen

Reported by: jane Owned by: greuben
Milestone: 3.2 Priority: low
Severity: normal Version: 3.1
Component: Menus Keywords: has-patch needs-testing
Focuses: Cc:

Description

If you View All on the Menus screen, it lists all pages but has them in alphabetical order rather than showing nesting/hierarchy like it does on edit.php?post_type=page (or in categories box on post editor). For sites with a lot of pages, having to remember/recreate the hierarchy in the menu is a pain in the butt. It would nice for the View All view for Pages (and custom post types with hierarchy) to display as they do in the regular pages list on edit.php?post_type=page instead of alphabetically.

Attachments (3)

17029.diff (1.8 KB) - added by greuben 4 years ago.
17029.2.diff (2.0 KB) - added by greuben 4 years ago.
typo fix and also includes taxonomies
17029.3.diff (2.0 KB) - added by greuben 4 years ago.
Coding standards: if ( not if(

Download all attachments as: .zip

Change History (17)

comment:1 @nacin4 years ago

Decided to close #14660 as a duplicate. There's also #14180 for hierarchical taxonomies.

comment:2 @filosofo4 years ago

Patch assumes that #16372 has been committed.

comment:3 @filosofo4 years ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 3.2

comment:4 @scribu4 years ago

For categories: #14180

comment:5 @scribu4 years ago

Also, this ticket is technically a duplicate of #14660

comment:6 @nacin4 years ago

filosofo: Looks like you meant this patch to land on #16799.

comment:7 @filosofo4 years ago

  • Keywords has-patch removed
  • Owner set to filosofo
  • Status changed from new to assigned

Whoops. I'll take ownership of this one, too, though.

comment:8 @ocean904 years ago

Related: #17221

comment:9 @maorb4 years ago

  • Cc maor@… added

@greuben4 years ago

comment:10 @greuben4 years ago

  • Keywords has-patch added; needs-patch removed

@greuben4 years ago

typo fix and also includes taxonomies

comment:11 @greuben4 years ago

  • Keywords needs-testing added

comment:12 @scribu4 years ago

Looks good. Tested with additional custom hierarchical taxonomies and post types.

@greuben4 years ago

Coding standards: if ( not if(

comment:13 @filosofo4 years ago

  • Owner changed from filosofo to greuben

comment:14 @ryan4 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In [17796]:

Show hierarchy for pages and taxonomies in nav menus admin. Props greuben. fixes #17029

Note: See TracTickets for help on using tickets.