WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 5 months ago

Last modified 2 months ago

#17036 closed defect (bug) (worksforme)

Theme editor shouldn't override root directory files with same names in child directories

Reported by: kawauso Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Themes Keywords: needs-patch theme-editor
Focuses: administration Cc:

Description

Steps to reproduce:

  1. Create subdirectory: blogs
  2. Create file in subdirectory: index.php
  3. Try selecting Main Index Template in Theme Editor

Example is taken from BuddyPress' theme structure. get_file_description() doesn't account in any way for the presence of subdirectories since it uses basename().

Change History (9)

#1 @kawauso
9 years ago

Duplicate: #10429 (without proper detail)

Last edited 9 years ago by kawauso (previous) (diff)

#2 @SergeyBiryukov
9 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to Future Release

Related: #4131

#4 @nacin
7 years ago

  • Component changed from Administration to Themes
  • Focuses administration added

#5 @obenland
6 years ago

  • Keywords theme-editor added

#6 @SergeyBiryukov
6 years ago

#30663 was marked as a duplicate.

This ticket was mentioned in Slack in #core-customize by melchoyce. View the logs.


3 years ago

#8 @Howdy_McGee
5 months ago

  • Keywords changed from needs-patch, theme-editor to needs-patch theme-editor
  • Resolution set to worksforme
  • Status changed from new to closed

I'm not sure this is an issue with the "new" Theme Editor. I could not replicate the issue using the above instructions and was able to update both independently and successfully without error.

#9 @SergeyBiryukov
2 months ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.