WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#17045 closed defect (bug) (duplicate)

Blog tags do not accept symbols

Reported by: will@… Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Taxonomy Keywords:
Focuses: Cc:

Description (last modified by dd32)

I work for a company developing a website using WordPress for a client on their own web hosting package (hostgator). We are using WordPress 3.1 so are up to date with the latest fixes.

I have noticed a bug with the post tag system. The system does not recognise symbols effectively. The website related to a management consultancy approach which defines people into one of 6 moods, the moods all use symbols as follows:

F+
F-
F~
T+
T-
T~

Given this information we wanted to create a tag cloud for them. However when tagging any post with the above moods the symbols are not accepted effectively.

Steps to reproduce:

1 - Create a new post (or use an existing post)
2 - Add the tag F+ to the post
3 - Publish / update the post
4 - You will see this tag works
5 - Add another tag ... for example F-
6 - Publish / update the post
7 - You will see the tag has not worked
8 - You can now add any of the F tags and tey are all taken as the first (F+) so the subsequent tags will now work

I imagine this problem has affected other users before but I could not find mention of it in another bug report or on the support forums so I hope this is a genuine bug and it's not wasting your time

Change History (8)

comment:1 follow-up: dd323 years ago

  • Component changed from Administration to Taxonomy
  • Description modified (diff)

Duplicate of #12125

You'll need to set a unique slug for the items manually, F+ F~ etc all sanitize to the same slug causing the odd issue you're hitting.

I'll leave this open for now to review it tomorrow

comment:2 garyc403 years ago

Related: #16567

comment:3 in reply to: ↑ 1 will@…3 years ago

Replying to dd32:

Duplicate of #12125

You'll need to set a unique slug for the items manually, F+ F~ etc all sanitize to the same slug causing the odd issue you're hitting.

I'll leave this open for now to review it tomorrow

Thanks for the prompt response ... and the fix ... it is hugely appreciated!

comment:4 will@…3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

comment:5 scribu3 years ago

  • Milestone Awaiting Review deleted

comment:6 ryan3 years ago

  • Resolution changed from duplicate to fixed

(In [17730]) kses optimizations. Props duck_. fixes #17045

comment:7 ryan3 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Wrong ticket. Ignore that changeset.

comment:8 ryan3 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.