WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#17070 closed defect (bug) (fixed)

Metaboxes not draggable in IE 8 and IE 9

Reported by: JDTrower Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: External Libraries Keywords: reporter-feedback
Focuses: Cc:

Description (last modified by scribu)

While doing testing of jQuery 1.5.2 for ticket #16426 (I was comnparing how things worked with the included versions of jQuery and jQuery UI in 3.0.5, 3.1.1, and 3.2-bleeding r17614 to how things worked with jQuery 1.5.2 in 3.2-bleeding r17614), I encountered an issue with not being able to drag metaboxes in IE 8 or IE 9 on Windows 7 64-bit. I was able to reproduce this on two different computers with WP 3.0.5, WP 3.1.1, and latest trunk version (r17614). Here's what I encountered in each version for each of the browsers above.

WP 3.0.5 + jQuery 1.4.2 + jQuery UI 1.7.3 - dashboard metaboxes are movable in IE 8

WP 3.0.5 + jQuery 1.4.2 + jQuery UI 1.7.3 - metaboxes on edit/new posts, links, and pages screens outline showing where to drop is slow if it shows at all in IE 8

WP 3.0.5 + jQuery 1.4.2 + jQuery UI 1.7.3 - no metaboxes are draggable in IE 9

WP 3.1.1 + jQuery 1.4.4 + jQuery UI 1.8.9 and WP 3.2-bleeding + jQuery 1.4.4 + jQuery UI 1.8.9 and WP 3.2-bleeding + jQuery 1.5.2 + jQuery UI 1.8.9 (and jQuery 1.8.11) - dashboard and edit/new links metaboxes are movebable in IE 8

WP 3.1.1 + jQuery 1.4.4 + jQuery UI 1.8.9 and WP 3.2-bleeding + jQuery 1.4.4 + jQuery UI 1.8.9 and WP 3.2-bleeding + jQuery 1.5.2 + jQuery UI 1.8.9 (and jQuery 1.8.11) - metaboxes on edit/new posts and pages are slow to drag and outline showing where to drop is slow if it shows at all in IE 8

WP 3.1.1 + jQuery 1.4.4 + jQuery UI 1.8.9 and WP 3.2-bleeding + jQuery 1.4.4 + jQuery UI 1.8.9 and WP 3.2-bleeding + jQuery 1.5.2 + jQuery UI 1.8.9 (and jQuery 1.8.11) - dashboard metaboxes are not movebable in IE 9

WP 3.1.1 + jQuery 1.4.4 + jQuery UI 1.8.9 and WP 3.2-bleeding + jQuery 1.4.4 + jQuery UI 1.8.9 and WP 3.2-bleeding + jQuery 1.5.2 + jQuery UI 1.8.9 (and jQuery 1.8.11) - reorder of metaboxes on edit/new posts, links, and pages screen in right column and dragging metaboxes from right column to left column works while dragging metaboxes from left column to right column doesn't work and results in a ghost metabox appearing

As a side note, I did try adding in the code that I discovered was causing the problem for #16955 to ui.sortable.js and it made no difference in what I am encountering in IE 8 and IE 9.

Change History (9)

comment:1 dd323 years ago

Um... Can you summarize that at all?

It sounds like a duplicate of #16955 however?

comment:2 nacin3 years ago

Chart please? :-)

comment:3 JDTrower3 years ago

I was told that my original description was too wordy so here is a summarized version.

WP 3.0.5 + jQuery 1.4.2 + jQuery UI 1.7.3 - dashboard metaboxes are movable in IE 8

WP 3.0.5 + jQuery 1.4.2 + jQuery UI 1.7.3 - metaboxes on edit/new posts, links, and pages screens outline showing where to drop is slow if it shows at all in IE 8

WP 3.0.5 + jQuery 1.4.2 + jQuery UI 1.7.3 - no metaboxes are draggable in IE 9

WP 3.1.1 + jQuery 1.4.4 + jQuery UI 1.8.9 and
WP 3.2-bleeding + jQuery 1.4.4 + jQuery UI 1.8.9 and
WP 3.2-bleeding + jQuery 1.5.2 + jQuery UI 1.8.9 (and jQuery 1.8.11) - dashboard and edit/new links metaboxes are movebable in IE 8

WP 3.1.1 + jQuery 1.4.4 + jQuery UI 1.8.9 and
WP 3.2-bleeding + jQuery 1.4.4 + jQuery UI 1.8.9 and
WP 3.2-bleeding + jQuery 1.5.2 + jQuery UI 1.8.9 (and jQuery 1.8.11) - metaboxes on edit/new posts and pages are slow to drag and outline showing where to drop is slow if it shows at all in IE 8

WP 3.1.1 + jQuery 1.4.4 + jQuery UI 1.8.9 and
WP 3.2-bleeding + jQuery 1.4.4 + jQuery UI 1.8.9 and
WP 3.2-bleeding + jQuery 1.5.2 + jQuery UI 1.8.9 (and jQuery 1.8.11) - dashboard metaboxes are not movebable in IE 9

WP 3.1.1 + jQuery 1.4.4 + jQuery UI 1.8.9 and
WP 3.2-bleeding + jQuery 1.4.4 + jQuery UI 1.8.9 and
WP 3.2-bleeding + jQuery 1.5.2 + jQuery UI 1.8.9 (and jQuery 1.8.11) - reorder of metaboxes on edit/new posts, links, and pages screen in right column and dragging metaboxes from right column to left column works while dragging metaboxes from left column to right column doesn't work and results in a ghost metabox appearing

As a side note, I did try adding in the code that I discovered was causing the problem for #16955 to ui.sortable.js and it made no difference in what I am encountering in IE 8 and IE 9.

Version 0, edited 3 years ago by JDTrower (next)

comment:4 scribu3 years ago

  • Description modified (diff)

Moved the summarized version to the ticket description.

Last edited 3 years ago by scribu (previous) (diff)

comment:5 JDTrower3 years ago

Thanks Scribu. Hoped someone with that privilege would do that for me. :)

comment:6 azaozz3 years ago

  • Version set to 3.0

comment:7 sbressler3 years ago

  • Cc sbressler@… added

comment:8 ocean903 years ago

  • Keywords reporter-feedback added

WordPress 3.2 comes with jQuery UI 1.8.12 and jQuery 1.6.1.

Maybe you can do some (or the same) tests again?

comment:9 azaozz3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to fixed
  • Status changed from new to closed

As far as I can tell all metaboxes are working properly in all supported versions of IE. Closing as fixed with the jQuery and jQuery UI updates, reopen if the problem still exists.

Note: See TracTickets for help on using tickets.