WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1708 closed defect (bug) (worksforme)

Typo with $object->property statements causes PHP5 to give fatal errors.

Reported by: splee Owned by:
Milestone: Priority: high
Severity: major Version: 1.5
Component: General Keywords: php5 compatibility bg|squashed
Focuses: Cc:

Description

I have attached diffs for both the 1.5 tag and the trunk code.

PHP 5.0.5 gives the following error when get_settings() from wp-includes/functions.php is run under certain conditions (reproducable in the manage->tags page when the UltimateTagWarrior plugin is installed):

Fatal error: Cannot access empty property in /path/to/root/wp-includes/functions.php on line 246

Attachments (2)

1.5-object-property-typo.txt (644 bytes) - added by splee 10 years ago.
patch for the 1.5 branch
trunk-object-property-typo.txt (540 bytes) - added by splee 10 years ago.
patch for the trunk

Download all attachments as: .zip

Change History (7)

@splee10 years ago

patch for the 1.5 branch

@splee10 years ago

patch for the trunk

comment:1 @splee10 years ago

  • Priority changed from normal to high
  • Severity changed from normal to major

comment:2 @westi10 years ago

  • Keywords bg|has-patch added

comment:3 @masquerade10 years ago

I believe this bug is invalid.

A) UTW has been known to be broken in 1.6, looks like there are a few compatability checkins lately, try the latest version?
B) Even if this is a bug with WP, this is far from a proper fix, and this will break many other things.
C) I can't duplicate the problem

comment:4 @masquerade10 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Got MarkJaquith to try, couldn't duplicate either.

comment:5 @masquerade10 years ago

  • Keywords bg|squashed added; bg|has-patch removed
Note: See TracTickets for help on using tickets.