WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 8 months ago

Last modified 5 months ago

#17088 closed defect (bug) (worksforme)

Edit image icon broken in Internet Explorer 9 for referenced images with captions

Reported by: andrewspittle Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Media Keywords:
Focuses: Cc:

Description

The "Edit Image" icon fails in IE 9 when trying to edit an image that has been inserted from an external URL with a caption. Instead of bringing up the Edit Image screen nothing happens.

Removing the caption code for an externally referenced image allows it to then be edited normally.

To reproduce:

  1. Create a new post in WP 3.1.1
  2. Add an image from an external URL with a caption. You could use the following code:
    [caption align="alignnone" width="281" caption="Source: Wikipedia (by NASA)"]<img title="France" src="http://upload.wikimedia.org/wikipedia/commons/thumb/c/c4/Satellite_image_of_France_in_August_2002.jpg/780px-Satellite_image_of_France_in_August_2002.jpg" alt="France" width="281" height="216" />[/caption]
    
  3. Switch to the visual editor.
  4. Click on the image to bring up the two icons.
  5. Click the edit image icon.

Instead of bringing up the edit image dialogue the post will scroll to the top with the cursor before the first word. Nothing else happens.

This was tested in IE 9 in an installation of 3.1.1. The same steps to reproduce will work correctly in Safari 5.0.4 and allow you to edit an image.

Change History (5)

comment:1 azaozz3 years ago

Seems caused by the workarounds/fixes for IE9 in TinyMCE. Should work properly after updating to the latest TinyMCE in trunk (that will be available in 3.2). I'll see if we can come up with a fix in the meantime.

comment:2 SergeyBiryukov3 years ago

Still can be reproduced in 3.3-trunk.

comment:3 c3mdigital8 months ago

  • Keywords reporter-feedback added

Can anyone confirm that this can still be reproduced in 3.6 or trunk?

comment:4 azaozz8 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed some time ago.

comment:5 ocean905 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution changed from fixed to worksforme
Note: See TracTickets for help on using tickets.