Make WordPress Core

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#17101 closed defect (bug) (fixed)

No more Title autosuggest for hyperlinks in Visual Editor

Reported by: sabinou Owned by: azaozz
Milestone: 3.2 Priority: normal
Severity: major Version: 3.1
Component: Editor Keywords: has-patch
Focuses: Cc:


In short :
With the new hyperlinking window inside the Visual Editor that appeared with wordpress 3.1, we aren't suggested anymore a text in the Title field.

In details :

  • Before Wp 3.1, according to the previous titles we may have entered, as soon as we started typing one or more letters, the Visual Editor was suggesting us texts for the Title field.
  • Just like almost any other empty field to fill in inside an html page.
  • That stopped with WP3.1, from now on we have to type it entirely every time, nothing is suggested anymore

Why this is a problem :
Wordpress is entirely about making blogging easier and faster for the webmasters. Removing Title autosuggestion forces us to type a title every time. With the previous system, we were able to re-use titles we had previously typed, possibly adapting them after we chose what autosuggested line to keep, saving us a lot of time.
From my own experience, writing a long post taking 30 minutes containing a dozen hyperlinks, in average 3 more minutes are lost because of title typing and imagining. While it may seem to amount to nothing, that's 10% time lost.

Optional link :
I first reported the problem in that page of the Worpdress forum, you may find it interesting .
Andrew Nacin, a dev, found that explanation, in my opinion calling for a fix precisely :
«IIRC, browsers do autocomplete only when inputs have names. Our input is now missing a name. Adding it back should restore the autocomplete.
Actually, it's also set to autocomplete="off", which probably doesn't help either :-)

I hope I wasn't too confusing, this is my first bug report.

Attachments (1)

17101.diff (1.1 KB) - added by nacin 4 years ago.
Untested, but should work.

Download all attachments as: .zip

Change History (15)

#1 @nacin
5 years ago

  • Cc koopersmith jane added
  • Keywords ux-feedback added
  • Milestone changed from Awaiting Review to 3.1.2

Excellent bug report, thank you!

I'm moving this to 3.1.2 for review, to track that it's a regression in behavior. I think it was intentional (given autocomplete=off) but I'm not sure I agree with that. So also marking for ux-feedback.

#2 @jcnetsys
5 years ago

Mark Jaquith made the addition of the autocomplete=off (http://core.trac.wordpress.org/changeset/16561/trunk/wp-admin/includes/internal-linking.php)

I will ask him what the rationale behind this was.

#3 @nacin
5 years ago

No need, it didn't come from Mark. He's just the committer.

#4 @sabinou
5 years ago

I think I see the problem. I happily edited that file with autocomplete="on", and saw it was problematic.

With "on", ith the internal linking system, typing even a letter in the Title field, and then hitting the down or up arrows, will make wordpress select a post whose title starts with that letter, putting the hyperlink to that post in the URL field, and the title of that post in the Title field.

Instead of suggesting from previous titles, it suggests from existing posts and overwrites the URL :(

The linking forcibly tries to be internal.

Version 0, edited 5 years ago by sabinou (next)

#5 @sabinou
5 years ago

I commented too fast, could it be a caching issue ? Four hours later, the autocomplete is now working correctly, as in the past before wordpress 3.1, not anymore forcibly trying to link to existing posts.

#6 @jcnetsys
5 years ago

The change was from Mark - he says 'Because it's annoying and not really relevant for such a field.'

#7 @sabinou
5 years ago

If a prominent dev told that, does it mean there will be no change ?

I'm not a prominent dev, and I have no way to assume I represent a majority of the webmasters, however, simply stating my opinion, I believe this is a MAJOR regression, going to cause stress and loss of time for most of the Wordpress users.

You'll find HTML laudators writing their posts directly in source code, without the Visual Editor. You'll find Mark, finding this is annoying.

However, the persons using the Visual Editor are obviously going for simplicity and time saving over perfection, right ? For these persons, I believe it makes sense to enable all the functionalities meant to make the life simpler for people, including autosuggestion.

My opinion is that the majority of the users would agree with me, however, of course, I have no way to be certain of it.

#8 @nacin
5 years ago

  • Milestone changed from 3.1.2 to Awaiting Review

#9 @kristofferR
4 years ago

  • Severity changed from minor to major

Please fix this! My dad (who runs his own Wordpress-site) was really frustrated by this, it meant a lot more work to him. I've hacked it back together for now (by editing wp-admin/includes/internal-linking.php), but it'll break with the next update.

This episode has made him VERY reluctant to update Wordpress again, fearing removal of more vital features. He probably will never update Wordpress again, I fear I have to do it for him (and then hack-fix the file).

I don't understand why removal of vital features like this is positive, it only discourages updating Wordpress.

#10 @nacin
4 years ago

  • Milestone changed from Awaiting Review to 3.2

Our current opinion is that it isn't really relevant, as expressed above. I don't agree though -- my address bar URL field autocompletes, so why shouldn't it here?

I'm going to move this to 3.2 for consideration. It should either be changed back, or wontfix'd.

#11 @markjaquith
4 years ago

If someone can give me a working patch, we can add autocomplete to the URL and title fields (not search, obviously). "href" and "linktitle" were the name values previously.

4 years ago

Untested, but should work.

#12 @nacin
4 years ago

  • Keywords has-patch added; ux-feedback removed

#13 @azaozz
4 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In [18207]:

Enable autocomplete on the href and title fields in the link popup, props nacin, fixes #17101
Remove unneeded for=".." attributes from the <label> tags there.

#14 @azaozz
4 years ago

Bear in mind that the list of suggestion for the URL field may become very large as they all start with http://

Note: See TracTickets for help on using tickets.