WordPress.org

Make WordPress Core

Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#1712 closed defect (bug) (worksforme)

Broken links

Reported by: mondalaci Owned by:
Milestone: Priority: normal
Severity: major Version: 1.5.2
Component: General Keywords: broken link links url urls uri uris
Focuses: Cc:

Description

Hi,

After I've upgraded from WordPress 1.2.x to WordPress 1.5.2 I realized that many links were broken on my site.

More specifically:

1) On the index page the links of the monthly archives were broken.

2) On the index page the links of the individual posts were broken.

3) On the index page the link "Previous Entries" and on its related pages the link "Next Entries" were broken. Instead of the correct URL http://monda.hu/%7Elaci/blog/index.php?paged=2 WordPress generated the false URL http://monda.hu/%7Elaci/blog/~laci/blog/index.php?paged=2.

4) On the "Edit Post" page the "Delete this post" button redirected to a non-existing URL.

5) On the "Options" page the "Update Options" button redirected to a non-existing URL.

There were probably more boken links on my Wordpress installation, but at that time I only knew about these. I have successfully investigated and fixed these problems and I want to report what I've found.

First of all, I'd like to point out that I'm using a Unix-style URL for my blog which contains a tilde character which in many cases the source of my problems. My "WordPress address" and "Blog address" are both http://monda.hu/~laci/blog

The fixes of the above problems:

1) In wp-includes/template-functions-links.php in line 75 I replaced the string '/?p=' with '/index.php?p='.

2) Same in line 122 I replaced the string '/?m=' with '/index.php?m='.

3) In wp-includes/template-functions-links.php I replaced the lines 368-370 which set the $index variable with the whole path of index.php rather than 'index.php' in it with "$index = 'index.php';".

4) In wp-admin/post.php I've commented out line 467 which removed the tilde character from my blog URL.

5) Same in wp-admin/options.php with line 86.

I came to the conclusion that:

a) In case 1) and 2) WordPress falsely assumed that my web server resolves implicit URLs like http://server/path/?a=b to http://server/path/index.php?a=b. In my situation this resolution hasn't happened.

b) In case 3) WordPress heavily messed up the URL because of a bug. Please correct me if it's not a bug.

c) I case 4) and 5) WordPress falsely removed the tilde out of the URL for some strange reason.

Thank you in advance and make me know if you need more help on this issue!

Laci

Change History (2)

#1 @matt
13 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

#2 @(none)
11 years ago

  • Milestone 2.0 deleted

Milestone 2.0 deleted

Note: See TracTickets for help on using tickets.