WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#17167 closed enhancement (duplicate)

require() path consistency

Reported by: niallkennedy Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: General Keywords: has-patch
Focuses: Cc:

Description

I see relative require paths built as both './wp-load.php' and dirname( __FILE__ ) . '/wp-load.php' inside PHP files at the project root. Pick one for consistency?

Attached is a patch for wp-activate showing an example of the two path references within a few lines of each other.

Attachments (1)

wp-activate.diff (453 bytes) - added by niallkennedy 4 years ago.
two types of require paths

Download all attachments as: .zip

Change History (2)

@niallkennedy4 years ago

two types of require paths

comment:1 @duck_4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #17092

Note: See TracTickets for help on using tickets.