WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 4 years ago

#17181 closed defect (bug) (wontfix)

IIS 7.5 Wordpress MU ms-files.php not streaming mp3 files correctly

Reported by: jacobm21 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Media Keywords: needs-patch
Focuses: multisite Cc:
PR Number:

Description

I think there is an issue with IIS and compression.

I have two MP3s, one is around 7MB and the other around 2MB. I can "download to folder" for both and that works fine, but if I play in the browser the 7MB version cut off after 30seconds (I tried this on multiple MP3s larger than 5MB). I thought this had something to do with the "Transfer-Encoding chunked" header. Upon further investigation I found that to disable this, I just had to specify the Content-length, which is explicitly disabled for IIS in ms-files.php (line 42). I commented out that line and now everything is working fine. I'm sure there was a reason for it, but I am not sure what for.

Change History (8)

#1 @ramoonus
9 years ago

  • Component changed from General to IIS

#4 @nacin
6 years ago

  • Component changed from IIS to Media
  • Focuses multisite added

#5 @chriscct7
4 years ago

  • Keywords needs-patch added

This ticket was mentioned in Slack in #core-multisite by jeremyfelt. View the logs.


4 years ago

#7 @jeremyfelt
4 years ago

  • Milestone Awaiting Review deleted
  • Version changed from 3.1 to 3.0

We discussed this ticket for a bit during multisite bug scrub today. I'm going to close it out as a wontfix. A couple lines of thinking here:

  • We don't entirely know the reason why Content Length was removed for IIS only.
  • This does not appear to be a wide spread issue. It's possible future versions of IIS handle something in a slightly different way.
  • ms-files.php has been disabled by default for 4 years, so the number of eyes we have available to test this has decreased significantly.

Not using rewriting via ms-files is the best way to have better control over static assets.

I think it could make sense to revisit if someone can dig in to a series of reproducible steps to test. Please feel free to reopen with new info.

#8 @jeremyfelt
4 years ago

  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.