WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 10 months ago

Last modified 10 months ago

#17200 closed defect (bug) (worksforme)

[Search] Posts containing search terms missing from Search Results

Reported by: newmediarts Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Query Keywords: reporter-feedback
Focuses: Cc:

Description

I tried to perform a search based on some text within this article on my site, specifically “Jason Sanchez”, but got no results.

Furthermore, when I search for "CNN" (for example), only two entries come back:

…but not this one, even though it should.

Other searches had similar problems (e.g., searching for "video", etc.). WordPress' built-in search seems to have some serious flaws in its search algorithm. I'm hoping you can resolve this in an upcoming release.

Change History (5)

comment:1 scribu3 years ago

  • Keywords close added; needs-patch removed

I copied "The Importance of the Web to Help Disaster Relief in Haiti" and "Web Foundation, Tim, Steve Featured on CNN Segment" to my test install and they both show up, as expected, when doing a search for 'cnn'.

It can be either some code in your theme or a plugin causing the trouble.

I couldn't copy the "Iqbal Z. Quadir" because I was redirected to it's parent page.

Last edited 3 years ago by scribu (previous) (diff)

comment:2 newmediarts3 years ago

  • Keywords close removed

@scribu: I also have a local development instance of the site on my machine, as well as a staging instance. I've tried disabling all the plugins and retrying the searches in both environments, but they still don't show up in the results.

comment:3 scribu3 years ago

  • Keywords reporter-feedback added

Maybe attach a text file containing the exact content (as it shows up in the edit screen) of the post that isn't showing up in the search.

comment:4 dd323 years ago

newmediarts: Can you install the "Debug Bar" plugin & add define('SAVEQUERIES', true); to your wp-config.php file; Once that's done, Perform the search and click the Debug button in the Admin Bar, if you can copy the queries made to check that nothing is being excluded?

If you recognise the search query amongst them, You can try running that against MySQL directly to see if that's returning the post.. I'd be interested in seeing the outcome of that too.

comment:5 SergeyBiryukov10 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Severity changed from major to normal
  • Status changed from new to closed

Feel free to reopen with the steps to reproduce on a clean install if there's still a problem.

Last edited 10 months ago by SergeyBiryukov (previous) (diff)
Note: See TracTickets for help on using tickets.