WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#17237 closed defect (bug) (fixed)

Images inserted into the wrong spot in IE

Reported by: designsimply Owned by: azaozz
Milestone: 3.2 Priority: normal
Severity: major Version:
Component: TinyMCE Keywords: needs-patch
Focuses: Cc:

Description

When using Internet Explorer to insert images in the latest trunk (r17700), the images always get placed at the top of the post. This causes problems when inserting images with captions because the cursor gets stuck inside the caption and the next content or image added gets mixed up with the image/caption markup and causes all sorts of trouble.

Expected behavior: Images get placed where the cursor was positioned before clicking the insert image icon.

Actual behavior: Images are stuck to the top of the content area instead of being inserted where the cursor was.

This problem happens across IE versions. Confirmed in IE 7/8/9.

Suspected culprit: TinyMCE. /cc @azaozz

Change History (3)

comment:1 azaozz3 years ago

  • Owner set to azaozz
  • Status changed from new to reviewing

comment:2 nacin3 years ago

  • Milestone changed from Awaiting Review to 3.2

comment:3 azaozz3 years ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

(In [17701]) Fix image insertion in IE, fixes #17237

Note: See TracTickets for help on using tickets.