WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 8 years ago

#17280 closed feature request (duplicate)

Ability to filter by post format in the Edit Posts screen

Reported by: iamfriendly Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2
Component: Administration Keywords: dev-feedback
Focuses: Cc:

Description

Hey all,

I've done a few different searches here but haven't found a ticket similar to this, but apologies if it already exists.

It'd be really handy to be able to filter the posts listed on the Posts>Posts screen by Post Format (if post formats are enabled in the theme).

Am I alone in thinking this is a good idea? (It wouldn't be the first time :) )

Change History (4)

#1 @jane
10 years ago

  • Keywords dev-feedback added

As opposed to text filters up with All | Published | Draft | Sticky etc, I would say the first step is to get the label off the title in the list table, and add a column (also in screen options) for Post Format, then give the individual formats listed in that column the same word-link-acts-as-filter treatment we have in the other columns. That way people who don't care about seeing formats here because they only use one can hide it, and it would make the title column easier to scan (save me from things like "Password Protected, Draft - Gallery" labels all jumbled on the end of the title).

#2 @helenyhou
8 years ago

  • Component changed from UI to Administration

#3 @helen
8 years ago

#16047 for the columns

#4 @helen
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15323.

Note: See TracTickets for help on using tickets.