WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#17286 closed defect (bug) (fixed)

Problems with require_once with php 5.3..5

Reported by: cardy_web Owned by:
Milestone: Priority: normal
Severity: critical Version: 3.1
Component: Administration Keywords:
Focuses: Cc:

Description

I've upgraded my server to php 5.3.5 from 5.2.16 few months ago without any problems. Wordpress worked like a charme until I've tried to go to the admin area where I received a blank page.
I enabled WP_DEBUG and I've found that function wp_dashboard_setup() didn't exists.
I've fixed this problem replacing require_once directive with require on line 10 and 14 in wp-admin/index.php
I've done the same replacement on nav-menus.php and update-core.php.
I've changed no setting or installed any new plugin so I think the problem is caused by some unknown incompatibilities.
The solution worked very well without any noticeable side effect.

Change History (7)

comment:1 cardy_web3 years ago

  • Cc cardy_web@… added

comment:2 scribu3 years ago

  • Keywords reporter-feedback added; has-patch dev-feedback removed

That's strange. I use PHP 5.3.5 both on my local install and on another server without any problems.

Did you try disabling all plugins and switching to the twentyten theme?

comment:3 cardy_web3 years ago

No I didn't because the site is online. I think is not theme or plugin related because everything worked well before upgrading php version. I've many local installation with php 5.3.x that works well.. Could it be a server configuration problem?

comment:4 andrewryno3 years ago

If you can't remove plugins or change the theme, install a fresh copy of WordPress elsewhere on the same server. While everything could have worked before the upgrade with no other changes, it could possibly be that a plugin doesn't work properly under 5.3.5 and is causing the problem.

comment:5 sivel3 years ago

The most common cause to this problem is an APC configuration, apc.include_once_override, which attempts to optimize include_once and require_once to avoid sys calls.

Check if this is enabled, and if so see if you can disable it. This should likely resolve your issue. This configuration option causes issues in just about every PHP application out there.

comment:6 cardy_web3 years ago

  • Keywords reporter-feedback removed
  • Resolution set to fixed
  • Status changed from new to closed

sivel you solved the problem. I rember now that before upgrading to php 5.3 I've had troubles with apc (it didn't work cause of an incompatibility issue). With php upgrade I've upgraded apc too 3.1.7. Now it's all ok.
Thank you for your help.

comment:7 scribu3 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.