Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#1729 closed defect (bug) (fixed)

Double-dash in blog URL gets replaced with long dash (bloginfo)

Reported by: Viper007Bond Owned by: ryan
Milestone: Priority: high
Severity: critical Version: 1.5.2
Component: Administration Keywords:
Focuses: Cc:


If -- is used in the blog URL, WordPress replaces with a – aka – when called via bloginfo(). bloginfo() shouldn't wptexturize() the URL outputs.

Reported here: http://wordpress.org/support/topic/46086

Change History (4)

#1 @westi
10 years ago

This is the same as #1545 I think.

#2 @ryan
10 years ago

  • Owner changed from anonymous to ryan

Yes, same root cause. We shouldn't texturize URIs.

#3 @Viper007Bond
10 years ago

Bah, I searched before making this ticket, but didn't see that one.

#4 @ryan
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [2935]) Don't run bloginfo filters on URIs. fixes #1545 #1410 #1729

Note: See TracTickets for help on using tickets.