WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#17300 closed defect (bug) (invalid)

New Site Creation Server Error

Reported by: xlrdxrevengex Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Network Admin Keywords:
Focuses: multisite Cc:

Description

Ok so on wordpress 3.0.5 i can create a new site without any errors. But on 3.1.2 when i have the network setup and i go to create a new site it spits out an internal server error 500 and the apache2 error log shows this

malformed header from script. Bad header=No recipient addresses found i: site-new.php, referer:

from what i can find this has something to do with the mailer.

My setup is debian lenny running apache2 with mod_suPHP and php-cgi Now i know that error is because of php running as cgi but i dont get why i get the error now on 3.1.2 and never got it on 3.0.5

Also not sure if this is relevant due to the error but the network admin area only shows you have 1 site and 1 user but i had like 8 setups with one user

Change History (7)

comment:1 xlrdxrevengex3 years ago

  • Cc xlrdxrevengex@… added

comment:2 xlrdxrevengex3 years ago

  • Cc xlrdxrevengex@… removed

comment:3 xlrdxrevengex3 years ago

  • Severity changed from major to normal

ok so i installed WP-Mail-SMTP plugin and i no longer get the error. It appears that wordpress phpmailer setup needs fixin

but i still show 1 site and 1 user in the network admin dashboard right now section

comment:4 xlrdxrevengex3 years ago

ok so it works fine with the plugin and without the plugin on another computer. I cleared the cache on the first computer and it did not help do you think i should clear all the computers cache?

comment:5 xlrdxrevengex3 years ago

  • Resolution set to maybelater
  • Status changed from new to closed

comment:6 ocean903 years ago

  • Resolution maybelater deleted
  • Status changed from closed to reopened

comment:7 ocean903 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from reopened to closed

If you think this is a WordPress bug feel free to re-open the ticket. At the moment some steps to reproduce your problem are missing.

Maybelater is registered for enhancements/featue requestsa for later versions.

Note: See TracTickets for help on using tickets.