Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#17317 closed defect (bug) (invalid)

Parent/child categories losing displayed hierarchy in post edit

Reported by: Joe Owned by:
Milestone: Priority: normal
Severity: major Version: 3.1
Component: General Keywords:
Focuses: Cc:


Basic install of wordpress 3.1.2 with parent & child categories set up. When a new post is created, parent & child categories are ordered perfectly in the right hand side "categories" box.http://imageshack.us/photo/my-images/821/21962812.jpg/

When the post is saved (either publish or as a draft) and the post is returned to, to edit: any child category that wasn't selected is now displayed outside of its parent. http://img638.imageshack.us/i/28112281.jpg/

Tried with a fresh install of WordPress 3.1.2 with no plugins installed and the same thing still happens.

Change History (2)

#1 @Joe
5 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Not a bug but a "feature", although a VERY odd one... Fixed with the "Category Checklist Tree" plugin:http://wordpress.org/extend/plugins/category-checklist-tree/

Last edited 5 years ago by Joe (previous) (diff)

#2 @dd32
5 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.