Make WordPress Core

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#17318 closed defect (bug) (invalid)

if Featured Image is wider than defined Header Image, it becomes Post's header image

Reported by: senlin's profile senlin Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Post Thumbnails Keywords:
Focuses: Cc:

Description

I have noticed on Child Themes of Twenty Ten that if you upload an image via the Featured Image that is larger than the defined width of your header image (by default 940x198px), the freshly uploaded image replaces the header image for that Post.

The workaround is to upload an image that is less wide than the defined width of the header image (i.e. keep it less than 940px by default).

Attachments (1)

featimg-twentyten.jpg (183.8 KB) - added by senlin 13 years ago.

Download all attachments as: .zip

Change History (5)

#1 @dd32
13 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

This is a feature of the Twenty Ten theme.

If you don't like it, You can modify your child themes header.php to not include the code.

#2 @senlin
13 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

I think you misunderstood. This was not happening before 3.1.2. I am talking about the featured image becoming (read: replacing) the header image when it is wider than the defined header image width. See attached screenshot please for a visualisation.

#3 @dd32
13 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

I'm not sure why you didn't come accross it previously, But that is the expected behaviour of the theme, and has been since it was originally released.

#4 @senlin
13 years ago

whatever

Note: See TracTickets for help on using tickets.