WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#17338 closed defect (bug) (invalid)

Impossible to Remove Gravatars

Reported by: miqrogroove Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: WordPress.org site Keywords:
Focuses: Cc:

Description

I've been trying for months to get my wordpress.org gravatars removed from the Google Images cache. While it is not super critical to me personally, I wanted to have the reassurance that it was possible to do so, and it is apparently not possible.

Things I have tried:

  1. I changed my Gravatar image. While this did eventually update on wordpress.org, the original images are still stuck in Google.
  1. I clicked the "Don't use this image" link, hoping to get a 404 and then use Google's URL removal form. Instead, I got a generic Gravatar logo.
  1. I clicked the "Delete this e-mail address" link, which does nothing at all. Other than not displaying my address on my profile, that button seems to be completely broken.

Results:

My "changed" gravatar is still being displayed for certain size parameters, while the Gravatar logo is being displayed for others. Despite my e-mail address being removed, the Gravatar servers still happily respond to the hashed address.

I could see this type of situation becoming a nightmare for webmasters and blog commenters alike. It poses serious privacy and terms of use issues that seem like they would not be easily resolved, also creating potential legal problems.

Change History (3)

comment:1 @miqrogroove4 years ago

Regarding results:

Although I still can't get any 404 response, I found that if I use Ctrl+Reload in Chrome it will show me either the Gravatar logo or a default gravatar instead of my "changed" image. That particular quirk is caused by the local cache.

comment:2 @miqrogroove4 years ago

Looks like the Gravatar servers use an invalid Last-Modified header:

Last-Modified: Wed, 11 Jan 1984 08:00:00 GMT

That may be preventing any type of web cache from refreshing itself.

Last edited 4 years ago by miqrogroove (previous) (diff)

comment:3 @dd324 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Gravatar is not a WordPress.org Project, rather, an Automattic project. I suggest you report this to Automattic/Gravatar instead, as this is not a WordPress issue.

Note: See TracTickets for help on using tickets.