Make WordPress Core

Opened 13 years ago

Closed 13 years ago

#17345 closed enhancement (worksforme)

Incorrect slash in URL when pagename parameter used

Reported by: egorpromo's profile egorpromo Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1.2
Component: General Keywords:
Focuses: Cc:

Description

Suppose I have 2 pages and page-1 is a parent of page-2. So I can see my page-2 in this way: http://mysite.ru/?pagename=page-1/page-2
But this is incorrect because there is one rule in the latest RFC. All symbols except . _ ~ 0-9 a-z A-Z in URL after ? must be URL encoded.
Additionally if I have permanent URL and I use http://mysite.ru/?pagename=page-2 i have redirect to http://mysite.ru/page-1/page-2/?pagename=page-2. And I have page 404 "Not Found" here, but if i erase all symbols after ? sign all is correct.

Change History (4)

#1 @edwardw
13 years ago

  • Resolution set to invalid
  • Status changed from new to closed
  • Version 3.1.2 deleted

Unable to reproduce with trunk revision 18519 - WordPress either uses page_id in the query string or pretty .htaccess rewriting, but not pagename as a query identifier.

#2 @SergeyBiryukov
13 years ago

  • Milestone Awaiting Review deleted
  • Version set to 3.1.2

#3 @nacin
13 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

pagename is a valid public query var, so not sure this invalid. Perhaps canonical should be kicking in.

#4 @edwardw
13 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

Still not reproducible with latest trunk - the page_id is added to query string automatically even if pagename is used.

Note: See TracTickets for help on using tickets.