Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#17346 closed defect (bug) (worksforme)

The search function can't find numbers?

Reported by: JonezJeA Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.1.2
Component: General Keywords:
Focuses: Cc:


My friend once wrote an article about his birthday. He became 18 and the article his title had the name: 'the first blog as adult, 18 years.'
A month later I wanted to link to it and I gave by the search bar in the link function in: '18 years' and the blog didn't show up.... only if I looked for 'adult'. Is this because that the function can't use numbers are is there more to this story?

Change History (1)

comment:1 @dd324 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

works for me: http://dd32.id.au/?s=23+year (first entry contains "23 years old")

SQL Looks correct too:

(((wp_posts.post_title LIKE '%23%') OR (wp_posts.post_content LIKE '%23%')) AND ((wp_posts.post_title LIKE '%year%') OR (wp_posts.post_content LIKE '%year%')) OR (wp_posts.post_title LIKE '%23 year%') OR (wp_posts.post_content LIKE '%23 year%'))

If you can reproduce it on a server which you have access to the query log for, I'd be interested in seeing the problem first hand.. but I suspect a plugin might be interfering.. or.. something.

Note: See TracTickets for help on using tickets.