WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#17354 closed enhancement (duplicate)

Let the add_*_page() functions take an array

Reported by: markjaquith Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Plugins Keywords:
Focuses: Cc:

Description

For some of the admin header changes we're working on for the UI refresh, we need some more things to be specified when registering admin pages. Our existing functions take far too many parameters to be order-based. Let's have it accept a named array, which will be the exclusive way of specifying any new parameters we add.

Change History (3)

comment:1 @markjaquith4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from Let the add_*_menu() functions take an array to Let the add_*_page() functions take an array

Duplicate of #15067

comment:2 @nacin4 years ago

  • Type changed from task (blessed) to enhancement

comment:3 @nacin4 years ago

  • Milestone 3.2 deleted
Note: See TracTickets for help on using tickets.