WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#17380 closed defect (bug) (fixed)

Pending count in reply's "title" not decrementing properly after Approve and Reply

Reported by: DH-Shredder Owned by: ryan
Milestone: 3.2 Priority: normal
Severity: normal Version: 3.2
Component: Comments Keywords: has-patch
Focuses: Cc:

Description

When adding a reply to a comment by clicking "Approve and Reply", the "title" attribute of the comments_bubble next to the reply does not decrement.

More specifically, to reproduce:

  • Visit Comments Screen
  • Click "Reply" for an Unapproved Comment
  • Enter a comment
  • Click "Approve and Reply"
  • Mouse-over new comment, and note that the pending count has not changed, but the number of comments has.

Attachments (1)

17380.diff (1.8 KB) - added by DH-Shredder 3 years ago.
Moves the approval of the new comment to before the new list-item is created, so that the pending comment 'title

Download all attachments as: .zip

Change History (4)

DH-Shredder3 years ago

Moves the approval of the new comment to before the new list-item is created, so that the pending comment 'title

comment:1 nacin3 years ago

  • Milestone changed from Awaiting Review to 3.2

comment:2 DH-Shredder3 years ago

Since the patch description was cut off --
Previously, the approval happened after the new comment's list item was created.

The above patch moves that code before the new list item's creation, so that the pending comment's "title" attribute is updated properly.

comment:3 ryan3 years ago

  • Owner set to ryan
  • Resolution set to fixed
  • Status changed from new to closed

In [18100]:

Decrement pending count after Approve and Reply. Props DH-Shredder. fixes #17380

Note: See TracTickets for help on using tickets.