WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#17430 closed defect (bug) (worksforme)

publish date did not use timezone setting

Reported by: V.J.Catkick Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2
Component: Date/Time Keywords: reporter-feedback
Focuses: Cc:

Description

on 3.2-beta1-17916

when you published entry, the publish-date should be calculated with wordpress's timezone settings.

repro step
1) goto wordpress setting -> general -> timezone setting
2) change timezone setting to your local timezone
3) write entry and press publish button

result
the entry will be 'scheduled' (if timezone is plus range such as +9)

expected
timezone should be calculated (as 3.1 or previous version)

Change History (3)

comment:1 johnbillion3 years ago

  • Keywords reporter-feedback close added

I can't reproduce this (at r18064). My timezone is BST (UTC+1) and publishing posts works as expected.

I changed my timezone to UTC+9 and posts still published as expected.

comment:2 johnbillion3 years ago

  • Keywords close removed

comment:3 SergeyBiryukov3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Can't reproduce either. Feel free to reopen with more information if there's still a problem.

Note: See TracTickets for help on using tickets.