WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#17474 closed defect (bug) (duplicate)

jQuery UI 1.8.14

Reported by: ramoonus Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2
Component: External Libraries Keywords: has-patch
Focuses: Cc:

Description

Has been released today
For more info see http://blog.jqueryui.com/2011/05/jquery-ui-1-8-13/

Attachments (3)

jquery ui 1.8.12-to-1.8.13.patch (115.8 KB) - added by hebbet 3 years ago.
patch for jquery ui 1.8.13
jquery ui 1.8.12 to 1.8.14.patch (132.1 KB) - added by hebbet 3 years ago.
jquery ui 1.8.12 to FULL 1.8.14.patch (230.1 KB) - added by jczorkmid 3 years ago.
Here's a patch that includes and registers the remaining jquery-ui libraries.

Download all attachments as: .zip

Change History (13)

comment:1 nacin3 years ago

  • Milestone changed from Awaiting Review to 3.2

comment:2 hebbet3 years ago

  • Keywords has-patch added; needs-patch removed

added patch

comment:3 nacin3 years ago

Not sure what the changes are to wp-admin/css/login.dev.css. Otherwise, many thanks!

hebbet3 years ago

patch for jquery ui 1.8.13

comment:4 hebbet3 years ago

uploaded without it. didn't remember i changed login.dev.css for another ticket.

comment:5 follow-up: ryan3 years ago

  • Milestone changed from 3.2 to Future Release

It's getting late in the 3.2 cycle, and 1.8.12 is good enough. Let's push this to 3.3.

comment:6 ramoonus3 years ago

  • Keywords needs-patch added; has-patch removed
  • Summary changed from jQuery UI 1.8.13 to jQuery UI 1.8.14

comment:7 hebbet3 years ago

  • Keywords has-patch added; needs-patch removed

added updated patch

comment:8 in reply to: ↑ 5 ramoonus3 years ago

Replying to ryan:

It's getting late in the 3.2 cycle, and 1.8.12 is good enough. Let's push this to 3.3.

its just routine maintenance?

comment:9 follow-up: jczorkmid3 years ago

  • Cc jpenney@… added

Would it be possible to include the full jquery-ui, rather than the subset currently used in core? When plugins/themes want to use these additional features of jquery-ui they end up having to distribute it with the plugin, which can cause issues when core upgrades from one version of jquery-ui to another. Also multiple plugins will try and register the same additional feature script (sometimes in different ways causing scripts to load multiple times).

jczorkmid3 years ago

Here's a patch that includes and registers the remaining jquery-ui libraries.

comment:10 in reply to: ↑ 9 azaozz3 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.