WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 7 weeks ago

#17478 closed enhancement (duplicate)

Disable Comments for Pages / Disable Comments for Pages Site-Wide

Reported by: Dimitri Vorontzov Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1.2
Component: Comments Keywords: ux-feedback
Focuses: Cc:

Description

Ladies and gentlemen,

it's been suggested on the Forum that I start a new ticket here. I think it's a good idea.

Here's a couple of suggestions that I believe if implemented would greatly improve WordPress functionality and popularity:

1) Make the Display Widget for pages visible by default, the way it was before the WordPress 3.0. Many non-blog WordPress website owners, and many bloggers, want the comments for pages disabled, but have no idea how to do that, because the Discussion checkbox in the Screen Options panel for Pages is deselected by default. As a result, most people new to WP 3 have no idea that Discussion Widget even exists, and have trouble disabling comments on pages.

Disabling such comments is very necessary in many situations. For example, a page that includes only a contact form, shouldn't have comments. Most WordPress users do not need their portfolios, or their "About" pages commented – and so on.

2) Create the checkbox that would allow to toggle all comments (old and new) comments for all pages with one click – and a separate checkbox that would allow to toggle all comments (old and new) for all posts – site-wide.

Many WordPress based business websites have hundreds of pages, and it would save a lot of time if the owner or designer could just disable the comments by deselecting one checkbox. I do realize it can be easily done by commenting out the comments in the code, but wouldn't it be nicer to have it as a checkbox option?

Some of the owners of such sites want to have a blog on their site, too - and want to have comments as a traditional part of blog functionality. That's what comments for pages and posts should be toggle-able site-wide independently from each other.

For best experience, the post comments should also have a toggle checkbox. Some owners may want to disable comments for all posts site-wide, too.

To see where this request is coming from, please Google "disable comments for pages wordpress" and you will see that the issue does cause quite a bit of confusion.

Also please see this thread of the WordPress support forum about: http://wordpress.org/support/topic/disable-comments-for-page-option/

I hope this suggestion helps to improve WordPress – already the greatest open source CMS platform.

Best regards,

Dimitri Vorontzov

Change History (10)

comment:1 SergeyBiryukov3 years ago

  • Keywords ux-feedback added

comment:2 inspired8882 years ago

  • Type changed from enhancement to feature request
  • Version changed from 3.1.2 to 3.3

Thanks for posting this Dimitri.
I've also put a Feature Suggestion over on http://wordpress.org/extend/ideas/topic/option-to-turn-off-comments-on-new-pages-andor-posts-by-default

I want to clarity a point here.

In point 2) made by you Dimitri it appears to me you're requestion a check box that will activate or deactivate Comments for all EXISTING pages and / or posts. I am not sure if that's what you meant to say, but it sounds good to me. However, I would add that the following related feature is what some of us are requesting on the forum post you have referred to:

We would like the addition of a site settings option to set whether NEW posts have comments turned ON or OFF by default, AND another separate option to set whether NEW pages have comments turn on or off by default, for the reasons Dimitri has outlined above.

Currently there is one such setting option which affects PAGES and POSTS simultaneously, but not independently.

I would also like to add I am wondering why this feature request has not been reviewed in over 6 months? Is that on par with the time-frame it normally takes for feature requests to be reviewed?

Last edited 2 years ago by inspired888 (previous) (diff)

comment:3 SergeyBiryukov2 years ago

  • Version changed from 3.3 to 3.1.2

Version field indicates when the feature was initially suggested.

comment:4 avryl9 months ago

  • Component changed from General to Comments

comment:5 bi0xid9 months ago

  • Cc raven@… added

comment:6 helen9 months ago

There's a little bit of a UI scaling issue here, given that there can be any number of post types beyond the default posts and pages (and attachments).

For what it's worth, you can use bulk edit to turn on/off comments on existing posts/pages/etc. Not calling that a fix, but it is something that can currently be done.

comment:7 Bueltge8 months ago

  • Cc frank@… added

Maybe useful. Plugin if interests, have all solutions. Only the fallback is not inside the plugin.
https://github.com/bueltge/Remove-Comments-Absolutely

comment:8 jdgrimes7 months ago

For reference, this plugin sound like it does something similar (haven't tested it): http://wordpress.org/plugins/comment-control/

comment:9 SergeyBiryukov6 months ago

#25595 was marked as a duplicate.

comment:10 SergeyBiryukov7 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Type changed from feature request to enhancement

Point 1 suggests making the Discussion meta box (currently hidden in screen options) visible for pages by default. Due to lack of traction, I don't think we want to do that, but feel free to reopen if this is still relevant.

Point 2 is a duplicate of #27111, which has a patch.

Note: See TracTickets for help on using tickets.