WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#17532 closed enhancement (fixed)

Credits screen: show translators, untranslatable string, generic function name

Reported by: dimadin Owned by: nacin
Milestone: 3.2 Priority: normal
Severity: normal Version: 3.2
Component: General Keywords:
Focuses: Cc:

Description

  • Since locale is already passed to request, translators can be shown in credits too. GlotPress can return list of validators for that locale. One installation can have more than one locale so transients should be based on locale.
  • String "Core Contributors to WordPress %s" is untranslatable since version is returned in response, instead placeholder must be returned.
  • Function add_css() has generic name so I think that it should be prefixed.

Attachments (1)

credits_translators.patch (1.4 KB) - added by dimadin 3 years ago.

Download all attachments as: .zip

Change History (19)

comment:1 nacin3 years ago

We use add_css() in a number of other situations in core without issue. If a plugin defined that function, lots of things would break.

comment:2 nacin3 years ago

Placeholders are now returned in the response.

comment:3 nacin3 years ago

Hm, it's actually add_js() that gets used elsewhere.

comment:4 nacin3 years ago

In [17980]:

s/add_css/_wp_credits_add_css/. props dimadin, see #17532.

comment:5 nacin3 years ago

  • Keywords has-patch removed
  • Milestone changed from Awaiting Review to 3.2
  • Owner set to nacin
  • Status changed from new to accepted

We had been planning to add new groups including translators. I'll talk with Jane to see how scalable the API should become before implementing anything else.

comment:6 nacin3 years ago

In [18001]:

Update the Credits page for changes in the API. see #17532.

comment:7 nacin3 years ago

In [18002]:

Prepare the Credits page to handle translators. see #17532.

comment:8 nacin3 years ago

In [18004]:

Add paragraph tags around the blocks of contributors. see #17532.

comment:9 westi3 years ago

In [18005]:

Use context to tell the translators what to do and thereby remove a unused string.
Add a comment as to why we have translations after a return.
See #17532

comment:10 nacin3 years ago

In [18007]:

String swap. see #17532.

comment:11 nacin3 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

comment:12 nacin3 years ago

In [18162]:

Credits screen redux. Add external libraries, gravatars for language validators. Backed by a new API. fixes #17518, fixes #17532.

comment:13 follow-up: scribu3 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

The translators that don't have gravatars have incorrect links:

http://profiles.wordpress.org/users/0 http://profiles.wordpress.org/users/1

etc.

comment:14 in reply to: ↑ 13 westi3 years ago

Replying to scribu:

The translators that don't have gravatars have incorrect links:

http://profiles.wordpress.org/users/0 http://profiles.wordpress.org/users/1

etc.

It would be better to open new tickets for issues so that they don't get lost.

comment:15 nacin3 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Cannot reproduce using the latest response from the API. Please flush the transient if you're having trouble.

Closing as fixed. Re-open a new ticket with steps to reproduce (please provide the localization you're using -- ro_RO works for me) if you can.

comment:16 nacin3 years ago

My bad, I hadn't committed and deployed a fix. All set now.

comment:17 scribu3 years ago

Thanks, works now.

It would be better to open new tickets for issues so that they don't get lost.

It was a bug in the implementation of the current feature and I'm pretty sure it wouldn't get lost, since I re-opened the ticket.

Last edited 3 years ago by scribu (previous) (diff)

comment:18 scribu3 years ago

Though I admit a re-opened ticket looks worse in the timeline than a new one.

Last edited 3 years ago by scribu (previous) (diff)
Note: See TracTickets for help on using tickets.