Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#17534 closed defect (bug) (fixed)

Glitch with collapsed menus

Reported by: scribu Owned by: azaozz
Milestone: 3.2 Priority: normal
Severity: minor Version: 3.2
Component: Administration Keywords: has-patch
Focuses: Cc:


Found a small glitch when switching menus, while on an admin list screen:


The tables briefly moves to the left, a little.

Reproduced both in Firefox 4 and Chrome.

From what I can tell, just before a menu is about to be hidden, it doesn't maintain it's vertical possition, but goes back next to the button before it slides in.

Attachments (1)

17534.diff (499 bytes) - added by rosshanney 4 years ago.

Download all attachments as: .zip

Change History (8)

#1 @ocean90
5 years ago

Because it's not visible in the video: Could be the scrollbar on the right the problem?

#2 @scribu
5 years ago

Yep, it's the scrollbar that's briefly appearing and causing the glitch.

Doesn't happen in WP 3.1, by the way.

#3 @ocean90
5 years ago

Another video: http://www.screenr.com/CMj

The problem is, that the menu opens above the icon but closes on the original position (next to the icon).

#4 @westi
4 years ago

It would be nice to fix this.

Does anyone fancy writing a patch?

4 years ago

#5 @rosshanney
4 years ago

  • Keywords has-patch added

The margin of the submenu is being reset before its 'hiding' transition is complete. This doesn't matter if there is room for the submenu to expand next to its icon, or if the vertical scrollbar of the browser is already present, but otherwise causes the glitch.

Attached patch removes the margin reset, so that the submenu doesn't jump back to the level of the icon.

I think I'm correct in saying that there isn't a sliding transition (just 'on' or 'off') on submenus in 3.1 (or lower)?

#6 @ocean90
4 years ago

Thanks for the simple patch. Glitch fixed.

I think I'm correct in saying that there isn't a sliding transition (just 'on' or 'off') on submenus in 3.1 (or lower)?


#7 @azaozz
4 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In [18138]:

Fix collapsed menu transition glitch, props rosshanney, fixes #17534

Note: See TracTickets for help on using tickets.