WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#17536 closed defect (bug) (fixed)

stray closing tags printed by wp_plugin_update_row if current_user_can('update_plugins' ) and !is_network_admin() and is_multisite()

Reported by: mitchoyoshitaka Owned by: mitchoyoshitaka
Milestone: 3.2 Priority: normal
Severity: minor Version:
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

Seems a little contrived, but if current_user_can('update_plugins' ) and !is_network_admin() and is_multisite(), wp_plugin_update_row may be triggered for a plugin.

wp_plugin_update_row will then skip the block which prints <tr><td><div> and the upgrade message, but will still print the closing </div></td></tr> after calling the in_plugin_update_message-$file hook. Note this hook was intended (#9553) to be fired only when there actually is an upgrade notice being printed, so it can be safely moved into the conditional.

Attachments (1)

17536.diff (1.6 KB) - added by mitchoyoshitaka 3 years ago.

Download all attachments as: .zip

Change History (3)

mitchoyoshitaka3 years ago

comment:1 in reply to: ↑ description nacin3 years ago

  • Milestone changed from Awaiting Review to 3.2

Replying to mitchoyoshitaka:

Note this hook was intended (#9553) to be fired only when there actually is an upgrade notice being printed, so it can be safely moved into the conditional.

Based on my review, I agree.

comment:2 nacin3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

In [17984]:

Move the closing tags inside the same conditional in wp_plugin_update_row. props mitchoyoshitaka, fixes #17536.

Note: See TracTickets for help on using tickets.