WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 11 years ago

#17549 closed defect (bug) (maybelater)

Bold and Italic bug

Reported by: JonezJeA Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1.2
Component: TinyMCE Keywords:
Focuses: Cc:

Description

When you put a title in bold & italc in the middle of a post then weird stuff can happen. I tested this with various Wordpress installs (but all in Dutch) on Wordpress.com and in v3.1, v3.1.1 and v3.1.2 this bug is alive.

Step 1: Put in the middle a title in bold and italic
Step 2: Press enter and put 'middle', 'bold' and 'italic' off.
Step 3: Try to write something.

What will happen is that after the first letter all the letters will be placed in front of it!

Change History (9)

#1 @scribu
11 years ago

  • Component changed from Editor to TinyMCE

#2 @azaozz
11 years ago

Cannot reproduce this in trunk/beta1. I get this in the HTML editor after following the steps above:

<p style="text-align: center;"><em><strong>centered title</strong></em></p>
extra text

#3 @JonezJeA
11 years ago

Oh, I get the bug when I have this:

<p style="text-align: center;"><em><strong>This is a title</strong></em></p>
<p style="text-align: left;">eT</p>

#4 @azaozz
11 years ago

Still can't reproduce it. Trying all kinds of alignment, bold, italic, etc. combinations. Could you try removing format (second row of the toolbar) on the paragraph after the "title"?

However noticed another undesirable behavior: the editor tries to maintain the text styling (B, I, etc.) when starting new paragraph. By default this is the behavior in IE (somehow inconsistent) but not in FF and WebKit in contentEditable mode and can result in one or two empty <strong>, <em>, etc. elements that are left over at the end of the new paragraph.

TunyMCE has a setting to stop this which we should add.

#5 @azaozz
11 years ago

In [18025]:

Stop TinyMCE from trying to maintain text formatting when adding new paragraphs in FF and WebKit, see #17549

#6 @JonezJeA
11 years ago

The following video shows exactly what I do. It is the same in a hosted Wordpress install. The video is hidden on my youtube account. The other videos are Dutch because it is my only account and it is for a project with my friends. It was not easy to film it with one hand but I first pressed the 'r' and then the 't'.

link: http://www.youtube.com/watch?v=xvZhklalo_M

Two other things:

  • In the Wordpress.com dashboard, some things are missing. Can you guys fix that or do I need to report that to that other forum?
  • After I did CTRL + A and then backspace, my cursor was in the middle. After doing backspace again, I could not centre the text... (also shown in the video!)

#7 @scribu
11 years ago

Sidenote: There's special software for recording your screen. Google for 'screencasting'.

#8 @JonezJeA
11 years ago

Okay, thanks for the tip!

#9 @azaozz
11 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed

Still can't reproduce the reverse typing. In any case, looks like TinyMCE bug which would probably be fixed in newer release.

Note: See TracTickets for help on using tickets.