Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#17593 closed defect (bug) (invalid)

tag intersection searches e.g. /tag/foo+bar broken using default permalinks not custom

Reported by: polins Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1.2
Component: Query Keywords:
Focuses: Cc:


Tag intersection (=and) searches broken:

http://site.com/tag/foo+bar resturns the correct result only with custom permalinks setting, not the default.
The default permalinks result in ALL posts being returned, regardless of assigned tag.

However, http://site.com/?tag=foo+bar does work correctly.


http://site.com/tag/foo+nonexistenttag returns ALL posts regardless of tag, again, only with the default permalink settings.
(I'm guessing that the latter issue will be addressed at WP 3.2 via Ticket #17194?)

Setup: WP 3.1.2, 2010 1.2 theme, no plugins

Change History (4)

comment:1 @scribu4 years ago

  • Keywords reporter-feedback added

It's not really clear what the problem is, from your description.

Please post step-by-step instructions, along with expected and actual behaviour.

comment:2 @scribu4 years ago

Are you suggesting that with default (ugly) permalinks, http://site.com/tag/foo+bar doesn't work?

If so, then yes, of course it won't work. The correct URL in that case is http://site.com/?tag=foo+bar as you've found out. That's why they're called ugly permalinks.

comment:3 @polins4 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Pardon my ignorance. Apologies for taking up your time, scribu. :~(

comment:4 @scribu4 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted

No worries. You might want to try the support forums first, next time.

Note: See TracTickets for help on using tickets.