WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#17664 closed defect (bug) (fixed)

DFW: Text may be hidden on Webkit browsers

Reported by: ocean90 Owned by: azaozz
Milestone: 3.2 Priority: normal
Severity: normal Version: 3.2
Component: Editor Keywords:
Focuses: Cc:

Description

Steps:

  • Use TwentyEleven and go to add new post screen (visual mode)
  • Switch to DFW
  • Start to type
  • If the default editor height is reached it will be resized.
  • Now you should see the same as on this screenshot: http://grab.by/agGh

Tested on OS X Safari and Chrome, doesn't happen in Firefox.

Change History (7)

comment:1 @ocean904 years ago

The problem is the fix for IE in r18066.

comment:2 @azaozz4 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In [18137]:

DFW: restore editor width shortcuts, restore limited overwriting of the theme styling in TinyMCE, show the toolbar on mouse move in TinyMCE, improve the help, fixes #17503, fixes #17644, fixes #17664, fixes #17596

comment:3 @ocean904 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Sorry, it's not fixed.

Video on Chrome: http://www.screenr.com/N6Ts

comment:4 @azaozz4 years ago

  • Keywords reporter-feedback added; needs-patch removed

Don't see this happening in Chrome 11 (latest stable) on win7. The cause was having margin on the <body> which in turn is needed for IE8 as you point out. [18137] forces no margin or padding on the <body> which seems to work properly in both browsers. Could you try clearing the cache, etc. and retest again.

comment:5 @ocean904 years ago

  • Keywords reporter-feedback removed

Tested in Chrome 13 on Mac again, still exists. Tested now on Chrome 13 on Win 7, new Safari 4 install on Win 7 and Safari 4 on Mac, same problem. IE 7-9 is fine.

comment:6 @azaozz4 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In [18142]:

Fix WebKit browsers reporting document.body height shorter than it is, add classes to TinyMCE's body: 'wp-editor' or 'wp-fullscreen-editor', fix mousemove event in IE, fixes #17664

comment:7 @ocean904 years ago

Azaozz, thanks. :)

Note: See TracTickets for help on using tickets.