WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#17677 closed defect (bug) (fixed)

Notice: Trying to get property of non-object in /wp-admin/includes/template.php on line 1856

Reported by: greuben Owned by: ryan
Milestone: 3.2 Priority: normal
Severity: normal Version:
Component: Themes Keywords: has-patch twenty-eleven
Focuses: Cc:

Description

Login as an author to reproduce

Attachments (1)

2011.diff (961 bytes) - added by greuben 4 years ago.

Download all attachments as: .zip

Change History (7)

@greuben4 years ago

comment:1 @ryan4 years ago

  • Milestone changed from Awaiting Review to 3.2

comment:2 @ryan4 years ago

  • Owner set to ryan
  • Resolution set to fixed
  • Status changed from new to closed

In [18135]:

Check result of add_theme_page(). Return if false. Props greuben. fixes #17677

comment:3 @ryan4 years ago

Did it a bit differently just in case we add anything else to that function.

comment:4 @nacin4 years ago

In [18136]:

Document that add_submenu_page() might return false if ! current_user_can(). see #17677.

comment:5 follow-up: @nacin4 years ago

add_menu_page() and friends does not return false in this case. Can anyone think of a reason why?

comment:6 in reply to: ↑ 5 @greuben4 years ago

add_menu_page() and friends does not return false in this case. Can anyone think of a reason why?

Maybe because top level menus should always exist to show low cap level menus if any.

add_action( 'admin_menu', function(){
	add_menu_page( 'test', 'test', 'manage_options', 'test', '__return_false' );
	add_submenu_page( 'test', 'test-2', 'test-2', 'read', 'test2', '__return_false' );
} );
Note: See TracTickets for help on using tickets.