WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 19 months ago

#17679 closed enhancement (duplicate)

Last Item in Publish Meta Box Not Necessarily Last

Reported by: cgrymala Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.2
Component: Administration Keywords: ui-feedback
Focuses: Cc:

Description

Because the post_submitbox_misc_actions filter is hooked at the end of outputting the misc-publishing-actions div, the element with a class of misc-pub-section-last might not actually be the last item in the meta box.

Therefore, I would propose that instances of misc-pub-section-last be removed and that a class of misc-pub-section-first be added to the first element in each of those instances. Then, the border-bottom style definitions would be changed to border-top, instead.

That way, no matter how many new elements are added below the last static element in the metabox using the post_submitbox_misc_actions filter, the borders will always be correct (since no filters/actions are called before the first element is output into either of the metaboxes that use that class).

It looks like these changes would effect:

  • /wp-admin/includes/meta-boxes.php
  • /wp-admin/edit-form-comment.php
  • /wp-admin/css/wp-admin.dev.css
  • /wp-admin/css/wp-admin.css
  • /wp-admin/css/wp-admin-rtl.dev.css
  • /wp-admin/css/wp-admin-rtl.css

Are there valid reasons why this change shouldn't/couldn't be made? If not, I'll work on a patch to make this change and see what it looks like. Thank you.

Change History (3)

comment:1 azizur3 years ago

  • Cc azizur added

comment:2 crstauf3 years ago

  • Cc crstauf added

comment:3 nacin19 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #19604.

Note: See TracTickets for help on using tickets.