WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#17688 closed defect (bug) (worksforme)

Backspace Lag in Visual Editor under FF 4 with Win 7

Reported by: macmanx Owned by: azaozz
Milestone: Priority: normal
Severity: normal Version: 3.2
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Two of our users on WordPress.com have so far reported that backspacing is strangely slow in the Visual editor when using Firefox 4.0.1 while hardware acceleration is active.

Both users are running Windows 7, but with different hardware.

I was unable to duplicate the problem under Windows Vista, so this looks like it's specific to just Windows 7. Co-worker Veselin Nikolov noticed a 16 millisecond lag when backspacing on his rather powerful Windows 7 machine, which could certainly magnify itself on much slower PCs.

He tested again on a self-hosted 3.1.3 blog and noticed a 12 millisecond lag, so this appears to definitely be related to TinyMCE, though I suppose it could also be a bug with Firefox 4 running under Windows 7.

To reproduce, type something the Visual editor via Firefox 4 under Windows 7 with hardware acceleration active, and start backspacing.

Original report: http://en.forums.wordpress.com/topic/very-slow-typing-and-slow-dashboard

Change History (3)

comment:1 azaozz3 years ago

  • Owner set to azaozz
  • Status changed from new to reviewing
  • Version changed from 3.1.3 to 3.2

Cannot reproduce this on win7 and FF 4.0.1.

There has always been some lag when using backspace as there isn't a native browser support for it in contentEditable/body.designMode. TinyMCE implements it's own methods to handle the HTML tags/DOM nodes when backspacing.

The lag is usually minimal (not noticeable) even on slower computers and older browsers. It depends on the browser and on how deep in the DOM the selected element/caret is. It also can be affected by other TinyMCE plugins. 0.016 sec. lag sounds about right. On older computers and older browsers it can go as high as 0.07 sec. but that is still unnoticeable for the user.

Don't think there is a direct link between hardware acceleration and this. It's the speed of Javascript running in the browser. It rather looks like FF4 problem on win7 when running intensive JS and hardware acceleration is on.

comment:2 macmanx3 years ago

Just updating that the user has confirmed the issue continues in Firefox 5. It still seems to be fine for me under Windows Vista, and I don't currently have a way of testing under Windows 7.

comment:3 azaozz3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from reviewing to closed

Still can't reproduce on win7. As "hardware acceleration" refers to the video card/driver, could this be a bug with FF and newer graphic cards? Or perhaps graphic cards/drivers that use the latest Directx 11?

In any case think this belongs on FF's bug tracker, there's nothing we can do to fix it.

Note: See TracTickets for help on using tickets.