WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#17700 closed enhancement (duplicate)

Limited control of comments in regards to attachements.

Reported by: sterlo Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: Comments Keywords:
Focuses: Cc:

Description

Attachments default to using the attachment page: "?attachment_id=###"

If "Allow people to post comments on new articles" was checked (as it is by default) then people can post comments on these assets.

There's no way to turn that off on any existing asset.

One solution is to disable that before uploading any assets.
Then...delete all existing assets and re-upload them...

I think it's reasonable to allow people to disable it on a per asset basis since it's something you can do on a per post/page basis.

IMO: It shouldn't be an all or nothing feature.

Change History (5)

comment:1 sterlo3 years ago

As per nacin I tested to see if comments on the asset were disabled if the parent (if one existed) had it's comments turned off.

It did not.

comment:2 sterlo3 years ago

Duplicate of #8177 and #9839

comment:3 sterlo3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

comment:4 anointed3 years ago

  • Cc anointed added

comment:5 ocean903 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.