WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#17721 closed defect (bug) (duplicate)

TinyMCE adds <div> after using <ul><li>

Reported by: hebbet Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2
Component: TinyMCE Keywords: needs-patch dev-feedback
Focuses: Cc:

Description

Repro:

create a new post/page

insert a text

create a new unsorted list with at least one item

press enter twice (removes you from list)

enter text.

switch to html mode.

you will get something like:

text
<ul>
	<li>list 1</li>
	<li>list 2</li>
</ul>
<div>text</div>

Tested with latest stable Chrome (12 since today), Firefox 4.0.1 running ubuntu 11.04 and latest wordpress nightly.

Change History (5)

#1 @hebbet
10 years ago

after testing with tinymce demos, i noticed it is a bug in tinymce itself.

Filled a bug there:
http://tinymce.moxiecode.com/develop/bugtracker_view.php?id=4454

#2 @azaozz
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This is fixed in the current dev/alpha version of TinyMCE and seems duplicate of #17154.

#3 follow-up: @itsalltech1
10 years ago

  • Keywords dev-feedback added
  • Resolution duplicate deleted
  • Status changed from closed to reopened

Is there any ETA on when this will be added into WordPress? Is there anyway to integrate the fix now?

#5 in reply to: ↑ 3 @azaozz
10 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Replying to itsalltech1:

Is there any ETA on when this will be added into WordPress?

3.3 will include the latest TinyMCE. And this ticket is still a duplicate of #17154.

Note: See TracTickets for help on using tickets.