WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 19 months ago

#17782 closed defect (bug) (duplicate)

Inconsistent border in Pages menu box tab

Reported by: scribu Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

Compare to Categories tabs:

http://i.imgur.com/5tdsK.png

Change History (3)

comment:1 scribu3 years ago

We should really try to use the generic .wp-tab-bar and .wp-tab-active classes.

comment:2 nacin3 years ago

  • Milestone 3.2 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Re-opened #17699 as it was never fixed.

comment:3 WraithKenny19 months ago

If you drag the Cat box up to change the order, the border might effect Cat instead of Pages.

Bug is sort of difficult to reproduce as it has to do with fractional pixel values and the elements' position on the page (In particular, when the document "flow" places the element's origin at a fractional pixel value). Browser's won't "subpixel render" a border, but instead rounds it to the nearest pixel for screen rendering. The border only shows when rounded in certain cases. (This isn't a browser bug, but intended.)

For example, I have the Publish box followed by Cat and the border shows up. If I change Publish box (not the Category box) css height (via Firebug) from 251.3px (calculated value) to 251px or any other full pixel value, the border bug goes away on Category.

Perhaps using some sort of "vertical rhythm grid" (which is to say, a style standard that enforces full pixel line-heights http://24ways.org/2006/compose-to-a-vertical-rhythm ) would fix this bug, and make the admin that much nicer.

Anyway, the root problem is that the ul css height is calculated to be 16.2px combined with a prior element of a fractional pixel height causes the border to be "rounded up" on display.

Note: See TracTickets for help on using tickets.