WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 8 years ago

Last modified 8 years ago

#17848 closed enhancement (wontfix)

Not possible to add a file field to the "add term" form

Reported by: DreadLox Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Taxonomy Keywords: 2nd-opinion
Focuses: Cc:

Description

The "add term" form now uses ajax. The downside is that it is not anymore possible to add an additional file field using a plug-in as it won't be sent over ajax.

The easy way to fix this is to use the already included jquery.form script for that form. That plugin will make the form submit into a hidden iframe if a file field is found inside the form.

Change History (3)

#1 @dd32
10 years ago

  • Keywords 2nd-opinion added
  • Summary changed from Regression: Not possible to add a file field to the "add term" form to Not possible to add a file field to the "add term" form
  • Type changed from defect (bug) to enhancement

Ajaxification of the Add Category page was done in 2.1, so this is a Regression from 2.0..

There's nothing preventing a plugin from switching to jQuery.form, It should only require enqueuing the Jquery.form script and the helper code to enable it for that form.

Marking as an enhancement and removing the regression marker since it's not a regression from something recent..

#2 @ericmann
8 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

This isn't a regression, and it isn't default functionality for WordPress - adding file fields would be something used in a plugin.

Since it's also possible to add this functionality through that plugin, it wouldn't make sense for core at this time.

#3 @helen
8 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.