WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#17849 closed defect (bug) (worksforme)

CSS issues in Quick Edit and Table nav (RTL-Arabic&Hebrew)

Reported by: rasheed Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: RTL Keywords:
Focuses: Cc:

Description

Hello,

Please check the attachment.

When making a quick post editing (at wp-admin/edit.php) the right border is invisible.

It looks to be related to font size:

#wpcontent select {
font-size: 12px;
height: 2em;
padding: 2px;
}

Changing the font size to 11px will make the right border to appear.

Attachments (4)

border.gif (53.7 KB) - added by rasheed 4 years ago.
17849.quick-edit-ff6-wp32.png (71.8 KB) - added by SergeyBiryukov 3 years ago.
17849.quick-edit-ff6-wp33trunk.png (78.3 KB) - added by SergeyBiryukov 3 years ago.
17849.quick-edit-update-button.png (5.4 KB) - added by SergeyBiryukov 3 years ago.

Download all attachments as: .zip

Change History (16)

@rasheed4 years ago

comment:1 follow-up: @SergeyBiryukov3 years ago

  • Keywords reporter-feedback added

Can't reproduce in 3.2.1 or 3.3-trunk with Firefox 7, Chrome 13 and Opera 11.51.

What browser is on the screenshot?

comment:2 in reply to: ↑ 1 @rasheed3 years ago

Replying to SergeyBiryukov:

Can't reproduce in 3.2.1 or 3.3-trunk with Firefox 7, Chrome 13 and Opera 11.51.

What browser is on the screenshot?

FF 6.0.2

comment:3 @SergeyBiryukov3 years ago

Hmm, that's what I see in 3.2.1 with Firefox 6: 17849.quick-edit-ff6-wp32.png (the border is in place).

Same in 3.3-trunk, but the screen has a couple of other issues: 17849.quick-edit-ff6-wp33trunk.png.

comment:4 follow-up: @SergeyBiryukov3 years ago

  • Keywords needs-patch added; reporter-feedback removed
  • Milestone changed from Awaiting Review to 3.3
  • Summary changed from border is invisible (RTL-Arabic) to Quick Edit CSS issues (RTL-Arabic)

comment:5 in reply to: ↑ 4 @rasheed3 years ago

comment:6 @ramiy3 years ago

Related: http://core.trac.wordpress.org/ticket/18314#comment:46

I have attached 2 screen-shots (Hebrew RTL) in #18314.

  • wp 3.2.1: No image "../18314/tablenav_class_in_posts_subpannel_wp321.png" attached to Ticket #17849
  • wp 3.3 beta1-18972: No image "../18314/tablenav_class_in_posts_subpannel_wp330beta.png" attached to Ticket #17849

comment:7 @ramiy3 years ago

  • Summary changed from Quick Edit CSS issues (RTL-Arabic) to CSS issues in Quick Edit and Table nav (RTL-Arabic&Hebrew)

comment:8 @nacin3 years ago

  • Keywords rtl-feedback added

comment:9 @azaozz3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Think these have been fixed as part of other RTL patches.

comment:10 @SergeyBiryukov3 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

The first issue on 17849.quick-edit-ff6-wp33trunk.png is fixed, but Cancel button is still displayed on the left. Should be on the right.

comment:11 @SergeyBiryukov3 years ago

Sorry, forgot to update to the latest revision.

There's still an issue with Update button though (see 17849.quick-edit-update-button.png). It's displayed too close to the border.

comment:12 @ocean903 years ago

  • Keywords needs-patch rtl-feedback removed
  • Milestone 3.3 deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

Can't see an issue here anymore, see attached screenshots:

FF 6: http://cl.ly/BxDJ

FF 8: http://cl.ly/Bwlw

Chrome 17: http://cl.ly/Bzii

Note: See TracTickets for help on using tickets.