Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#17858 closed defect (bug) (duplicate)

Bad widget holder position when position name is Footer

Reported by: newkind Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2
Component: Widgets Keywords:
Focuses: Cc:



I have created a ticket about exactly the same issue for the WP < 3.2 It was about having a widget position named 'Footer'. Because WordPress is taking the name of the position and using it as the ID of the holder div it lead to CSS conflicts resulting in bad styling. This actually got even worse for WP 3.2 In RC1 for 3.2 having a position named 'Footer' results in having holder to appear in the admin footer and Widget Position to look like it's not usable at all. I know it's a silly conflict but I think that this should be resolved at last as since version 3.2 it's going to be unusable. Using different names for positions is not a solution, because often position names are best reference of where the widgets are going to appear on the site - Footer position - widgets will appear in the Footer of the site.


Attachments (1)

widget_conflict.jpg (62.5 KB) - added by newkind 4 years ago.

Download all attachments as: .zip

Change History (2)

@newkind4 years ago

comment:1 @nacin4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14466.

Note: See TracTickets for help on using tickets.