WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#17867 closed defect (bug) (worksforme)

Credits Page - Fatal error: Only variables can be passed by reference.

Reported by: studionashvegas Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

Running the RC1 Nightly, and this pops up on my credits page.

Fatal error: Only variables can be passed by reference in /blahblahblah/wp-admin/credits.php on line 116

Change History (10)

comment:1 @studionashvegas4 years ago

  • Keywords close added

Fixed in the RC2

comment:2 @nacin4 years ago

  • Milestone changed from Awaiting Review to 3.2

Nothing changed since RC1. Moving to 3.2 for review. Let's get an extra set of eyes on this.

comment:3 @aaroncampbell4 years ago

I'm definitely not seeing this one. shuffle() is pass-by-reference so it requires a variable, and it's even been on line 116 for a while, but I don't see that we've ever passed it anything but a variable.

I can't reproduce.

comment:4 follow-up: @studionashvegas4 years ago

It was really strange because I saw the error on RC1, created the Trac ticket, upgraded to RC2, and it fixed itself. Should I check it on an RC1 fresh install?

comment:5 in reply to: ↑ 4 @nacin4 years ago

  • Keywords reporter-feedback added; needs-patch removed

Replying to studionashvegas:

It was really strange because I saw the error on RC1, created the Trac ticket, upgraded to RC2, and it fixed itself. Should I check it on an RC1 fresh install?

Yeah, if you can, that'd be great. Need to know what's going on there. What version of PHP?

comment:6 @nacin4 years ago

  • Milestone changed from 3.2 to Awaiting Review

comment:7 @edwardw4 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Seems to be fine as of trunk revision 18519.

comment:8 @aaroncampbell4 years ago

This was definitely NOT fixed in [18519]. I agree with closing as worksforme, but I wanted to point out that it wasn't fixed there in case anyone checks this in the future.

comment:9 @ocean904 years ago

  • Keywords close reporter-feedback removed
  • Milestone Awaiting Review deleted

edwardw says that revision 18519 was his current version on which he tested it again.

comment:10 @aaroncampbell4 years ago

I realized that, but not until I had checked the revision to see what had fixed it only to see that it was completely unrelated. I just wanted to make sure anyone else happening by didn't have to do the same thing.

Note: See TracTickets for help on using tickets.