WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#17919 closed defect (bug) (invalid)

"more" tag ignored

Reported by: xpLosIve93 Owned by:
Milestone: Priority: normal
Severity: trivial Version: 3.2
Component: Themes Keywords: needs-patch reporter-feedback
Focuses: Cc:

Description

In Wordpress 3.2 RC, the "<!--more-->" tag is ignored in the index page.
The entire of the post content is displayed on the index page.
No more link.

Change History (5)

comment:1 dd323 years ago

  • Component changed from General to Bundled Theme
  • Keywords reporter-feedback added

When you say on the index, Are you referring to using the Showcase Template?

Does the post have any post format specified?

As far as i can see, it works for me:

  • When using the normal index, <!--more--> works as expected
  • When using the Showcase Template, Featured Posts do not have <!--more--> at all, However all pages are displayed (as expected)
  • When using the Showcase Template, Posts which appear in the Recent Posts area, the <!--more--> link works as expected

comment:2 xpLosIve933 years ago

I made some new tests, and the problem only occurs on my template. No problem on Twenty 11. Impossible to find where is the problem on my template. I no have problems on Wordpres 3.1 and I use the_content('(Lire la suite...)'); on the index.php

comment:3 dd323 years ago

  • Component changed from Bundled Theme to Themes

Ah, oh, custom theme.

Are you using a theme from WordPress.org? Can you reproduce it with other themes?

Eitherway, we'll need to see an example of a theme that's having the issue in order to work out what might be causing it.

comment:4 xpLosIve933 years ago

  • Resolution set to invalid
  • Severity changed from major to trivial
  • Status changed from new to closed

Problem fixed. Due to my template, I used by error a $more var.

comment:5 dd323 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.