WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#17930 closed defect (bug) (worksforme)

flash uploader ie9 undefined error

Reported by: svenl77 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1.3
Component: Editor Keywords:
Focuses: Cc:

Description

If I try to upload a new image with the ie9 via the flash file uploader in the post edit screen, I get an undefined error with an annoying js error popup.

Attachments (2)

Bild395.jpg (27.5 KB) - added by svenl77 4 years ago.
Bild396.jpg (36.8 KB) - added by svenl77 4 years ago.

Download all attachments as: .zip

Change History (7)

@svenl774 years ago

@svenl774 years ago

comment:1 @azaozz4 years ago

  • Keywords reporter-feedback added; needs-patch removed

Looks like either a JS conflict or some of the JS files didn't update properly. Delete wp-includes/js and upload a fresh copy with FTP. If this continues, see what other JS files are loaded and try disabling them.

comment:2 follow-up: @svenl774 years ago

@azaozz, it happens on all wp sites on my server and there are hundreds. I checked now an older wp on a different server and it worked.

I have setup a clean website for testing. Same bug on my server, all the rest runs well.

comment:3 in reply to: ↑ 2 ; follow-up: @azaozz4 years ago

Replying to svenl77:

Can you look for any PHP notices or warnings in the uploader's iframe source. If none, add define('SCRIPT_DEBUG', true); to wp-config.php then when the error appears start the IE9 dev. tools and copy/paste the trace here.

(Would be nice to set both the test install and the browser to English too :)

Last edited 4 years ago by azaozz (previous) (diff)

comment:4 in reply to: ↑ 3 @svenl774 years ago

Replying to azaozz:

Hope this error message helps you. I'm kind of lost with debuging in ie as I'm working on mac.

This is done with parallels.

A friend of mine will try get more info for you from his windows browser

flashremoveCallback(document.getElementById(""), "TestExternalInterface");

flashremoveCallback(document.getElementById(""), "SelectFile");

HTML1115: X-UA-Compatible META tag ('IE=7') ignored because document mode is already finalized.
post-new.php
HTML1113: Document mode restart from IE9 Standards to Quirks
swfupload.swf?preventswfcaching=1309436895944
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328
SCRIPT5: Access is denied.

swfupload.swf?preventswfcaching=1309436895944, line 115 character 328

comment:5 @ocean904 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce the issue.

Please try also the trunk version, it has a new file uploader, see #18206.

Note: See TracTickets for help on using tickets.